Home Page Forums Raspberry Pi Shields 3G/4G LTE Base V2 and Pi-ZeroW –> auto-connect not working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #69556
    jeanchristophe
    Participant

    Hi,

    I’ve got a 3G/4G LTE Base V2 with a Pi-ZeroW.
    I’ve installed the Base shield using the install.sh script following instructions here: https://sixfab.com/ppp-installer-for-sixfab-shield/.
    Unfortunately, the connection only works when I type:
    sudo route del default
    sudo route add default ppp0

    I can see then when I reboot, I have to retype both lines again to get the connection working.
    I’v try to put these lines in a crontab @reboot, but it doesn’t seem working…
    Is it possible to add these two lines in the auto-connect script? If yes, where is the script that is launched at boot?

    Thanks in advance.

    #72456
    ensar
    Moderator

    Hello,
    Make sure that you have the following commands in /etc/ppp/ip-up. if you don’t add it.
    sudo route del default
    sudo route add default ppp0

    It asks you when installing.
    Do you want to activate auto-connect/reconnect service at R.Pi boot up?
    This option allows you to connect to the Internet via your shield automatically when your Raspberry Pi Starts. If you want to connect to the Internet automatically type y else N. If you have selected N then you will need to run sudo pon to connect to the internet and sudo poff to stop it. Make sure your module is powered up(Not applicable for Base Shield).

    Have a nice day.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.