Home Page Forums Raspberry Pi Shields 3G shield with UC20-G not connecting

This topic contains 4 replies, has 3 voices, and was last updated by  javhualde 7 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #36385

    javhualde
    Participant

    Hello guys!!

    I have the 3g/4g shield with the UC20-G,iḿ not able to connect, i followed the steps of the tutorial of ppp conection,but when i write in command “sudo pppd call gprs” or “sudo pon” i get the following error. ( I have on red light of power but not blue light of signal in the shield)

    pppd options in effect:
    debug # (from /etc/ppp/peers/gprs)
    nodetach # (from /etc/ppp/peers/gprs)
    dump # (from /etc/ppp/peers/gprs)
    noauth # (from /etc/ppp/peers/gprs)
    remotename 3gppp # (from /etc/ppp/peers/gprs)
    /dev/ttyUSB3 # (from /etc/ppp/peers/gprs)
    115200 # (from /etc/ppp/peers/gprs)
    lock # (from /etc/ppp/peers/gprs)
    connect chat -s -v -f /etc/chatscripts/quectel-chat-connect -T internet.digimobil.es # (from /etc/ppp/peers/gprs)
    disconnect chat -s -v -f /etc/chatscripts/quectel-chat-disconnect # (from /etc/ppp/peers/gprs)
    nocrtscts # (from /etc/ppp/peers/gprs)
    modem # (from /etc/ppp/peers/gprs)
    asyncmap 0 # (from /etc/ppp/options)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    hide-password # (from /etc/ppp/peers/gprs)
    novj # (from /etc/ppp/peers/gprs)
    novjccomp # (from /etc/ppp/peers/gprs)
    ipcp-accept-local # (from /etc/ppp/peers/gprs)
    ipcp-accept-remote # (from /etc/ppp/peers/gprs)
    ipparam 3gppp # (from /etc/ppp/peers/gprs)
    noipdefault # (from /etc/ppp/peers/gprs)
    ipcp-max-failure 30 # (from /etc/ppp/peers/gprs)
    defaultroute # (from /etc/ppp/peers/gprs)
    usepeerdns # (from /etc/ppp/peers/gprs)
    noccp # (from /etc/ppp/peers/gprs)
    noipx # (from /etc/ppp/options)
    abort on (BUSY)
    abort on (NO CARRIER)
    abort on (NO DIALTONE)
    abort on (ERROR)
    abort on (NO ANSWER)
    timeout set to 30 seconds
    send (AT^M)
    expect (OK)
    ^M
    OK
    — got it

    send (ATE0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
    expect (OK)
    ^M
    ^M
    Quectel^M
    UC20^M
    Revision: UC20GQCR03A16E1G^M
    ^M
    SubEdition: V03^M
    ^M
    +CSQ: 27,99^M
    ^M
    +COPS: 0^M
    ^M
    +CGREG: 0,2^M
    ^M
    OK
    — got it

    send (AT+CGDCONT=1,”IP”,”internet.digimobil.es”,,0,0^M)
    expect (OK)
    ^M
    ^M
    ERROR
    — failed
    Failed (ERROR)
    Script chat -s -v -f /etc/chatscripts/quectel-chat-connect -T internet.digimobil.es finished (pid 3603), status = 0x7
    Connect script failed

    I am a noob in Raspian and Linux
    Please help!!

    #36393

    Saeed
    Participant

    Hey, Could you please recheck the APN? It is not accepting the APN.

    #36395

    javhualde
    Participant

    Hello Saeed

    Thank you for your help!!!
    I tried with Digimobil company wich APN(regarding his webpage) is: internet.digimobil.es and it doesn work. (in my cellphone with these APN internet is working)
    I also tried with Movistar comapny SIM card, wich APN is :telefonica.es and still not working. (internet working in my cellphone)

    Any other clues? the antenna seems ok?

    Thank you again for your quick reply

    #36398

    Ray
    Participant

    Signal quality is ok

    +CSQ: 27,99^M

    But looks like you’re not registered to network:

    +COPS: 0^M
    +CGREG: 0,2^M

    Do you have the right band set in the modem for your carrier?

    Also, check if the SIM is working by putting it on smartphone.

    #36402

    javhualde
    Participant

    Thank you Ray
    Sim it’s already tested in my phone and it’s working.
    How do i set the band in the módem?

    Thanks again

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.