Home Page Forums Raspberry Pi Shields Can not connect to Pi using this board

Tagged: 

This topic contains 8 replies, has 3 voices, and was last updated by  ensar 1 month, 4 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #41268

    fborot
    Participant

    Hello
    We bought 2 of these devices and I have been trying to get them to work unsuccessfully.
    I have tried T-Mobile and ATT SIMs and most of the time I get not IP. I followed the steps here

    https://sixfab.com/qmi-interface-with-3g-4g-lte-base-shield-v2/

    and they all work fine until step 14. I ran the command:
    “sudo ./quectel-CM -s internet”

    I get to the point where I get IP address . When I do get an IP I can ping from the PI to yahoo.com for example but I can not access the Pi nor I can ping the PI.
    Also the loop never ends. So I have been running it like this
    “sudo ./quectel-CM -s internet &” to get the prompt back and be able to see the ifconfig output and verify that there is a default route

    Any ideas what can be causing this?
    Thank you

    Fabian

    #47856

    ensar
    Moderator

    Hi.

    sudo ./quectel-CM -s <APN> is a non ending loop as long as there is connection you cannot use the terminal.
    You would rather use new terminal for different commands (or other purpose. )

    #47859

    robert
    Participant

    Hi.

    Do you have a public accessible IP-address??
    Nowadays, if not provided with a fixed IP-address, you need to use OpenVPN or something else to be able to connect.

    #47865

    robert
    Participant

    Are you by the way sure you need to install the QMI-variant?

    https://sixfab.com/ppp-installer-for-sixfab-shield/ for PPP variant.

    #48541

    ensar
    Moderator

    Hi @robert.
    There is no fixed IP address.
    Yes you should install MI-variant.

    #49263

    robert
    Participant

    Hi ensar,

    It completely depends on the used simcard!

    We (our company) have our own APN and all our simcards have fixed IP-addresses.
    These simcards are not reachable from the outside world, only from within our cloud enviroment.
    We use a portal (reverse proxy) to gain access to the device, which works like a charm.

    I installed the 4G hat some time ago and used the ‘old’ instructions (page does not exist anymore)
    which guided me though the entire setup, the PPP-variant.

    Why would you choose for the MI-variant and not the PPP?

    #50088

    ensar
    Moderator

    Then you should install PPP. Try your own APN address.

    https://sixfab.com/ppp-installer-for-sixfab-shield/

    #50176

    robert
    Participant

    Hi Ensear,

    Are you replying to me??

    I have the 4G hat perfectly working, that’s why i replied to fborot to try the PPP variant…
    PS. I have 3 pieces running smoothly, waiting to get a go to order +50 more 😉

    • This reply was modified 2 months, 1 week ago by  robert.
    #52078

    ensar
    Moderator

    Oh sorry got it now….cheers 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.