Home Page Forums Raspberry Pi Shields Faulty Cellular IoT HAT?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #50613
    fathermaguire
    Participant

    Hi,
    I’ve got a Cellular IoT HAT that I’d like to use with an Asus Tinkboard. Initially I’d like to do a PoC via USB before getting into GPIO config etc. to access the embedded UART.

    However, when I attach the hat to, say, my Windows PC using the supplied USB cable there is no sign of life – no LEDs, no USB device detected etc. The same when I plug it into my Tinkeboard. When I do attach it via the header, the LEDs do come on (no response from any of the baked in ttySx devices). Don’t want to get into that yet though.

    Should the hat light up when plugged in via USB? I’ve tried the on-board buttons but still no sign of life.

    Any takers?
    Dougal

    #50615
    fathermaguire
    Participant

    Never mind. I assumed the hat drew power from USB but it doesn’t. Once I’ve connected the hat to the 40-pin header on the Tinkerboad and then connected the USB cable to the Tinkerboard I’m seeing the USB endpoints and additional UARTs.

    Dougal out.

    #51114
    ensar
    Moderator

    Hi,
    In order to maintain this RPi HAT requirement, the 5V of USB on the HAT is disconnected.
    If you want to use the HAT standalone with the USB without 40pins you can short 5V and VBUS as shown in the figure below.

    5V-HAT

Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘Faulty Cellular IoT HAT?’ is closed to new replies.