Home Page Forums Raspberry Pi Shields No GPS data

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by  nadeem.rnd 2 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #39766

    evert.bevernage
    Participant

    I’ve been trying to set up the EC25E gps module, but I can’t seem to get any position information:
    i’m using:
    – the 3g-4g/lte base shield v2
    – quectel ec35 miniPCIe 4g/lte module
    – triple uFl antenna

    This is the consistent output of /dev/ttyUSB1
    $GPVTG,,T,,M,,N,,K,N*2C
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPGGA,,,,,,0,,,,,,,,*66
    $GPRMC,,V,,,,,,,,,,N*53

    I’ve tried
    – to confirm all gps systems to be used (AT+QGPSCFG=”gnssconfig”,1)
    – Reconfigured to least accurate position and longest allowable time using AT+QGPS=1,255,1000,0,1
    – Going outdoors on a wide open square, no always the same information as above

    #47511

    Saeed
    Moderator

    Did you try with different antenna?

    #48717

    evert.bevernage
    Participant

    Took me a while to get a hold of a new antenna,

    But apparantly, it’s the natenna:

    #49600

    nadeem.rnd
    Participant

    Hi Saeed,
    I am using RPi 3 and BG96 App Shield module.
    I am in seattle WA, USA(North America).

    I am facing problem with the GPS data.
    I almost tried on 7 different devices and with three different kind of antenna (https://www.amazon.com/Beyondoor-External-Sensitivity-Magnetic-Straight/dp/B07PQKHWF7/), and apply the XTRA data fix as well, but still i am not able to get the GNSS data.
    After uploading the fix(Enable GPSone xtra: GPSone extra allows to download the ephemeris data ) successfully i got the response only couple of times and not able to get the GNSS data again. I have done setup in my backyard in open sky, and waited for whole night.

    Queries:
    1. Will the BG96 App Shield module works in North America? Or do we need to try other module.
    2. The same device is able to work in India.
    3. Please let us know if we need to upload any other fix or is there any known issue.

    I have tried below commands as suggested by collegue:
    g. On cutecom , send the command AT+QGPSXTRA=1
    h. AT+QGPSEND
    i. AT+QFUPL=”UFS:xtra2.bin”,60831,100
    j. After sending above command (step i), you will see a CONNECT indication. At this point of time, use the Send File button in the cutecom and select the xtra2.bin file that you have downloaded and click on send. After it is sent 100%, you will see a QFUPL indication telling that file has been uploaded correctly.
    k. Now send AT+QGPSXTRATIME=0,“2019/07/31,15:30:30”,1,1,5
    l. AT+QGPSXTRADATA=“UFS:xtra2.bin”
    m. AT+QGPS=1
    n. After sometime, send the command AT+QGPSLOC? Command. If you get +CME ERROR: 516 it means that the GPS fix is not yet obtained and we need to wait. Ensure that you are able to see the sky.
    Otherwise, you will get the fix.
    o. If you want to see the NMEA frames, you can open /dev/ttyUSB1 and on this port, the raw NMEA frames would be visible.

    Regards
    Nadeem

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.