Home Page Forums Raspberry Pi Shields North American AT&T APN for Quectel EC25-A

This topic contains 5 replies, has 5 voices, and was last updated by  albusumbra 8 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #36316


    I recently purchased a Raspberry Pi 3G-4G/LTE Base Shield V2 with a Quectel EC25-A modem and can’t get connected to AT&T. I maybe getting connected but when I run
    sudo pon the script gets to where it sends ATD*99# and the modem replies “CONNECT” and “got it” but then a few lines later I get “No auto is possible”. Could anyone tell me what is causing this error.
    Any help will be highly appreciated.
    Thanks in Advance



    I finally got the Quectel EC25-A working on AT&T! I had two sim cards from AT&T and one of them kept given me the No auth is possible when I ran sudo pon. I tried the other sim with the same modem and it worked right out of the gate.

    The APN for AT&T is broadband if anyone else needs it.

    The AT&T rep is sending another sim card tomorrow. So the main problem was that the sim wasn’t provisioned correctly or a bad sim.



    Thank you for your feedback and sharing your experience. 🙂



    I have the same setup, the Quectel EC25-A AT&T and the Raspberry Pi 3G-4G/LTE Base Shield V2. I have a sim card linked to another IMEI, so I talked to an AT&T rep to transfer that sim card to the Quectel IMEI and the rep says the Quectel is not compatible and not coming on in the system. Do you happen to know anything about this?



    Quectel EC25 A is certified for North America and AT&T.
    Please contact Quectel support for further details.



    You have to get a new sim card with an IMEI linked to the IMEI on the Quectel EC25A. They are unable to transfer existing sims because of a system limitation (what my rep said at least). For the apn I used pta instead of broadband, for anyone who still has issues.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.