Home Page Forums Raspberry Pi Shields Old Python Scripts

This topic contains 1 reply, has 2 voices, and was last updated by  Saeed 5 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36236

    rdcole
    Participant

    I have the IOT Shield and I tried in vain to get it running right after I got the board but nothing was working so I put it aside for another day, Today was that day.

    Today I started over, downloaded the Raspbian Stretch Lite image and worked from there. The old install was Python 2.7 so I decided to install a newer version of Python 3.5, turns out I have to edit all the scrips to make them compatible with Python 3.5 as well as chase down modules that are not installed. I should fo kept notes to write a new install script but I didn’t.

    I was elated when I finally got sensor_test to run.

    From there I went after the GPS Receiver and was able to get NEMA strings but with no data since I’m testing inside the house. Some GPS receivers work inside some don’t.

    I was able to install PPP as outlined with no errors, but it’s not tested yet.

    Then I tried the IFTT, that’s where I discovered that the Serial Port was hardcoded in the .egg file as /dev/ttys0 and that does not match my install. The shield shows up as /dev/ttyUSB0,/dev/ttyUSB1,/dev/ttyUSB2,/dev/ttyUSB3.

    Things looked like it was going to work then I ran into a Cellular SIM Roadblock. I’m trying to accessing T-Mobile USA NB-IoT network which is on Band B4, you get $10/year connectivity/device but, but it seems you must have an “IoT SIM”, not a regular Data SIM which was what I was using. So I ordered a new SIM through T-Mobile’s IoT partner twilio.com.

    I hope to get the SIM and be connected by February.

    We will see as I have lots of other things to get done.
    Like print a case for this thing a get the main Python code for my tracking application working.

    #36269

    Saeed
    Moderator

    Thank you for you feedback.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.