Home Page Forums Raspberry Pi Shields Quectel BG96 Modem on a RaspPi Cellular HAT – No Signal , SIM will not register

This topic contains 6 replies, has 3 voices, and was last updated by  Saeed 3 months, 4 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #37571

    kyleu1967
    Participant

    Hello,

    I am trying to work with this new raspberry pi modem HAT. Currently I am attempting to work the modem with my computer through USB and putty. I can send and receive commands through serial but nothing I do gets the modem to see RF signals or register the SIM. The test setup is as follows:

    1. Connected bench top PSU to the board capable of supplying up to 5 amps at 5 volts. (it draws about 80mA when its on and searching for signal, 50mA when idle). This should eliminate any under current issues.

    2. Connected a large 4G LTE CradlePoint brand antenna to the LTE port on the board. I have also tried several times with the Sixfab supplies Pulse Electronics one. I am also in an area with excellent AT&T 4G LTE signal.

    3. Connected the Sixfab board to my computer through the micro USB cable and started a terminal session.

    4. I turn on the power, wait 10 seconds then press the “pwrkey” button for 3 seconds. This wakes up the modem and then I can see the COM port display in my device manager. I then connect to the device through putty at a baud rate of 115200bps.

    5. Ensured that the AT&T SIM I am using is active. It is a Data only line with a private APN and static IP. I tested this SIM in two separate 4G CradlePoint modems and it works fine.

    Serial log with notes (#)

    # I set echo on
    ATE1
    OK

    # I set error codes to verbose
    AT+CMEE=2
    OK

    # display product info, modem mnfc, model, revision
    ATI
    Quectel
    BG96
    Revision: BG96MAR02A07M1G
    OK

    # Quectel modem IMEI number
    AT+GSN
    8664250XXXXXXXX
    OK

    # display status of the SIM. Ready indicates it does not require a PIN
    AT+CPIN?
    +CPIN: READY
    OK

    # query the initialization status of SIM card. (e.g. 3=1+2 means CPIN READY & SMS DONE).
    AT+QINISTAT
    +QINISTAT: 3
    OK

    # display SIM card number
    AT+QCCID
    +QCCID: 890141032760XXXXXXXX
    OK

    # display SIM International Mobile Subscriber Identity number
    AT+CIMI
    3104106XXXXXXXX
    OK

    # display phone functionality. 1 = Full function
    AT+CFUN?
    +CFUN: 1
    OK

    # display Signal Quality Report. RSSI and BER = Not known or not detectable
    AT+CSQ
    +CSQ: 99,99
    OK

    # Network registration status – Disable network registration unsolicited result code & Not registered, but MT is # currently trying to attach or searching an operator to register to.
    AT+CREG?
    +CREG: 0,2
    OK

    # Network Registration Status – Disable network registration unsolicited result code & Unknown
    AT+CGREG?
    +CGREG: 0,4
    OK

    # EPS Network Registration Status – Disable network registration unsolicited result code & Not registered, but MT is currently trying to attach or searching an operator to register to.
    AT+CEREG?
    +CEREG: 0,2
    OK

    That’s as far as I have gotten. Any ideas?

    Thank you,
    Kyle.

    #37642

    pnederveen
    Participant

    Kyle,

    Something else I thought of is that the CEREG or CGREG (packet switched) will not be able to complete until CREG (circuit switched) completes with x,1 or x,5.

    Paul

    #37643

    pnederveen
    Participant

    Kyle,

    this was the first response but forum is wonky ever since I tried to edit.

    This forum keeps complaining and not posting because I tried to edit. This is an effort to fool the dupe detector.

    You are on the right path. You have already done most of the important bits. One would actually expect it to probably work at this point…

    The problem I’ve seen on some of these BG96 modules is that default values are not always set the way the manual says. It depends on which flavor of FW is loaded on the module.

    no dupe

    I would suggest you check AT+COPS?
    and specifically set AT+COPS=0
    so that operator selection is automatic.

    If you want to know what networks are available in your area you can run AT+COPS=? and wait for a while.

    Furthermore, I have seen that the sixfab code does not always set all of the config (specifically QCFG) settings needed. I recommend

    AT+QCFG=”iotopmode”,0,1
    AT+QCFG=”nwscanseq”,020103,1
    AT+QCFG=”nwscanmode”,0,1
    AT+QCFG=”band”, 0F, 400A0E189F, A0E189F, 1

    You can tweak these depending on if you want 2G only or 2G, CatM1, NB-IoT, etc

    You will not get a useful CSQ back until you are registered on a tower to an operator. CREG will return x,1 or x,5 and COPS? will return non-0.

    Let us know if that works for you.

    Paul

    #37661

    Saeed
    Moderator

    Thank you for your answer.

    #37678

    kyleu1967
    Participant

    I found the issue. Here is what I ran:

    # Search for available operators. Waited 20 minutes. This command never resolved, had to reset the modem.
    AT+COPS=?

    # Set operator selection to automatic
    AT+COPS=0
    OK

    # RAT(s) to be searched. Default scan mode is in Automatic
    AT+QCFG=”NWSCANMODE”
    +QCFG: “nwscanmode”,0
    OK

    # Specifies network category to be searched under LTE RAT. The Documentation does not list -1 as an accepted value, only 0,1,2.
    AT+QCFG=”IOTOPMODE”
    +QCFG: “iotopmode”,-1
    OK

    # Specifies searching sequence of RAT. Default set to search LTE Cat NB1, M1, then GSM.
    AT+QCFG=”NWSCANSEQ”
    +QCFG: “nwscanseq”,030201
    OK

    # Sets the allowed RF bands to be searched. I switched these from the default values (0x1,0x10,0x80000) to the following:
    AT+QCFG=”band”
    +QCFG: “band”,0xf,0x181a,0x181a
    OK

    For At&t, these bands are of interest:

    Band Hex
    2 0x2
    4 0x8
    5 0x10
    12 0x800
    13 0x1000

    SUM 0x181A

    The value in AT+QCFG=”IOTOPMODE” seemed suspect. The documentation makes no note of “-1″ value. When i changed this to 0 through the following command (AT+QCFG=”IOTOPMODE”,0,1) It connected immediately!

    Thank you for your help! Going into this I knew nothing about modem AT commands. Now I think I’m getting the hang of it.

    #37680

    pnederveen
    Participant

    Kyle,

    Glad that helped.

    iotopmode of -1 is nothing I ever heard of. Curious where you got that or saw that listed?

    For sure, if you are attempting to connect to LTE (not 2G) then you will need iotopmode set properly. There is some evidence that the BG96 does not always contain proper default settings AND some settings are not persisting like they should.

    Now that you have the settings correct, you should be able to run ‘AT+COPS=?’ in order to see the available operators. Typically it will return in <5 min but it can take quite a while to scan all of the bands and modes.

    To my knowledge the only CatM1 you will see in the US is AT&T and Verizon, and in some places T-mo is deploying NB-IoT. It will vary by area.

    Paul

    #37710

    Saeed
    Moderator

    Thank you Kyle and Paul for sharing your experience and knowledge.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.