Home Page Forums Raspberry Pi Shields Quectel EC25-AF MiniPCIe 4G/LTE with T-mobile SIM

This topic contains 13 replies, has 6 voices, and was last updated by  peng1can 2 weeks, 3 days ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #37323

    monsiboney
    Participant

    Hi Saeed. Really, I need your help!!. Please.
    I have the Quectel EC25-AF over sixfab Mini PCle 3G,4G/LTE base shield and RPI3, I’m not able to connect to internet, I followed the steps of the tutorial of ppp connection, but I can’t see my ppp0 interface. This Quectel and sim works fine in my windows with a dongle and connect very fast to T-Mobile. I appreciate any help. Thanks a lot!!!

    [email protected]:~ $ sudo pon
    pppd options in effect:
    debug # (from /etc/ppp/peers/provider)
    updetach # (from /etc/ppp/peers/provider)
    dump # (from /etc/ppp/peers/provider)
    noauth # (from /etc/ppp/peers/provider)
    remotename 3gppp # (from /etc/ppp/peers/provider)
    /dev/ttyUSB3 # (from /etc/ppp/peers/provider)
    115200 # (from /etc/ppp/peers/provider)
    lock # (from /etc/ppp/peers/provider)
    connect chat -s -v -f /etc/chatscripts/chat-connect -T fast.t-mobile.com # (from /etc/ppp/peers/provider)
    disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
    nocrtscts # (from /etc/ppp/peers/provider)
    modem # (from /etc/ppp/peers/provider)
    asyncmap 0 # (from /etc/ppp/options)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    hide-password # (from /etc/ppp/peers/provider)
    novj # (from /etc/ppp/peers/provider)
    novjccomp # (from /etc/ppp/peers/provider)
    ipcp-accept-local # (from /etc/ppp/peers/provider)
    ipcp-accept-remote # (from /etc/ppp/peers/provider)
    ipparam 3gppp # (from /etc/ppp/peers/provider)
    noipdefault # (from /etc/ppp/peers/provider)
    ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
    defaultroute # (from /etc/ppp/peers/provider)
    usepeerdns # (from /etc/ppp/peers/provider)
    noccp # (from /etc/ppp/peers/provider)
    noipx # (from /etc/ppp/options)
    abort on (BUSY)
    abort on (NO CARRIER)
    abort on (NO DIALTONE)
    abort on (ERROR)
    abort on (NO ANSWER)
    timeout set to 30 seconds
    send (AT^M)
    expect (OK)
    ^M
    OK
    — got it

    send (ATE0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
    expect (OK)
    ^M
    ^M
    Quectel^M
    EC25^M
    Revision: EC25AFFAR07A03M4G^M
    ^M
    SubEdition: V05^M
    ^M
    +CSQ: 27,99^M
    ^M
    +COPS: 0,0,”T-Mobile”,7^M
    ^M
    +CGREG: 0,1^M
    ^M
    OK
    — got it

    send (AT+CGDCONT=1,”IP”,”fast.t-mobile.com”,,0,0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATD*99#^M)
    expect (CONNECT)
    ^M
    ^M
    CONNECT
    — got it

    Script chat -s -v -f /etc/chatscripts/chat-connect -T fast.t-mobile.com finished (pid 2807), status = 0x0
    Serial connection established.
    using channel 2
    Using interface ppp0
    Connect: ppp0 <–> /dev/ttyUSB3
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xeffa23a> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x3 <asyncmap 0x0> <auth chap MD5> <magic 0x1a2b010e> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x3 <auth chap MD5>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xeffa23a> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x4 <asyncmap 0x0> <magic 0x1a2b010e> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x4 <asyncmap 0x0> <magic 0x1a2b010e> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0xeffa23a]
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [LCP DiscReq id=0x5 magic=0x1a2b010e]
    rcvd [LCP EchoRep id=0x0 magic=0x1a2b010e 0e ff a2 3a]
    Modem hangup
    Connection terminated.
    [email protected]:~ $ ifconfig ppp0
    ppp0: error fetching interface information: Device not found
    [email protected]:~ $

    #37352

    xmicks
    Participant

    I have the same issue. help needed. Did you solve it?

    #37366

    monsiboney
    Participant

    Hi
    Nop, seems to be T-Mobile look the RBPi chipset or something. I can connect to the tower but I can’t surf because I don’t get valid IPV6 address. I’m continue search.. if you solve or find something please, share.
    Thanks

    #37654

    Saeed
    Moderator

    Hi,

    Which power source are you using? Make sure the device is getting enough power. Raspberry pi original Power adapter is recommended.

    #37663

    Saeed
    Moderator

    Could you also check with Fast.t-mobile.com as APN? (source)

    #37744

    sixfab15
    Participant

    Jumping in here because I have the same issue, both ppp and qmi are not working on tmo with the AF modem.

    This repeats:
    [04-23_20:29:14:127] requestSetOperatingMode(1)
    [04-23_20:29:14:158] requestSetOperatingMode(0)
    [04-23_20:29:14:638] requestRegistrationState2 MCC: 0, MNC: 0, PS: Detached, DataCap: UNKNOW
    [04-23_20:29:14:894] requestRegistrationState2 MCC: 310, MNC: 260, PS: Detached, DataCap: UNKNOW
    [04-23_20:29:15:726] requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
    [04-23_20:29:15:822] requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
    [04-23_20:29:15:854] requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe
    [04-23_20:29:15:886] requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
    [04-23_20:29:15:950] requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
    [04-23_20:29:15:982] requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe
    [04-23_20:29:21:134] requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
    [04-23_20:29:21:166] requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe

    Swapping with an EC25-A works fine and connects with an IP right away.

    #37762

    Saeed
    Moderator

    Hi, Does these repeat with EC25-A ?

    #37767

    sixfab15
    Participant

    No. If I put in the EC25-A the qmi script connects right away and returns with the IP.

    Could it be a bad modem?

    • This reply was modified 3 months, 3 weeks ago by  sixfab15.
    #38367

    markk
    Participant

    I have two routers one ZBT with Qualcomm chipset and one with Mitek chipset both work rock solid with Quectel EC25-A MiniPCIe 4G/LTE with T-mobile SIM. But put in Quectel EC25-AF MiniPCIe 4G/LTE with T-mobile SIM and same problem. Any help would be appreciated.

    #38368

    xmicks
    Participant

    I had to disable Bluetooth and the serial Com. Though keep serial enabled.

    After the module can connect to the internet, I had to delete the default route and add a new one for the ppp0 interface.

    I use T-Mobile in the Netherlands with “smartsites.t-mobile” as apn.

    Mick

    #38373

    markk
    Participant

    Hi Mick,

    Do you have a copy of the commands?

    #38374

    xmicks
    Participant

    Not exactly but if you search for “rpi disable Bluetooth”, you will find a guide for that.

    Also, in raspi-config you can disable serial command line, after that you will be asked if you still want serial to be enabled, you will answer “yes”.

    #38375

    xmicks
    Participant

    And for the default route part see:

    EXTRA
    Route: One of the possible errors you may get is routing error. In this case, run the following commands

    sudo route del default

    sudo route add default ppp0

    From: https://sixfab.com/ppp-installer-for-sixfab-shield/

    #40258

    peng1can
    Participant

    I’m having the same problem on T-Mobile (US) where using an EC25-A works fine, but swapping with EC25-AF results in the QMUXError = 0xe. I also have the same problem using a GL.iNet openwrt-based portable router (-A works, -AF doesn’t connect).

    Someone elsewhere reported having to get a different SIM. I think what may be happening is that the EC25-A is not certified for T-Mobile, so they have no idea what that device is and they just treat it as a phone. The EC25-AF *is* certified on T-Mobile, and since they do track devices such as tablets for their different discount plans, I’m guessing they have the EC25-AF MEID range listed as “not a phone” in their systems and won’t let it connect unless you subscribe to their much more expensive hotspot plans. The line I’m using for this purpose is literally free, so I’m probably not going to bother upgrading to a vastly more expensive plan to continue testing.

    • This reply was modified 2 weeks, 2 days ago by  peng1can.
Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.