Home Page Forums Raspberry Pi Shields Raspberry Pi 4G/LTE Shield Kit – …unexpected operator…

This topic contains 5 replies, has 2 voices, and was last updated by  john 3 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #37864

    john
    Participant

    Hello,
    when i connect Raspberry Pi 4G/LTE Shield Kit via USB port and followded https://sixfab.com/ppp-installer-for-sixfab-shield/ instructions, at the level “What is your device communication port?” I write ‘ttyUSB3’ i get the followed error on screenshot 1 :
    1
    After installation done.
    I type #sudo pon i get the error on screenshots 2 :
    2

    Here is my ipconfig with ppp0 and wwan0 interfaces :
    3

    Please i need your help to fix this and make the connection OK.

    • This topic was modified 3 months, 2 weeks ago by  john.
    #37921

    Saeed
    Moderator

    Hi,

    1. There was a bug which is fixed now.

    2. You are getting the error because the shield is already connected. Did you activate the auto connect service?

    3. ppp0 is showing up which means you are already connected via Shield.

    #37968

    john
    Participant

    Thank you it works.

    #37969

    john
    Participant

    Is it compatible with openWRT ?

    #37998

    Saeed
    Moderator

    Theoretically, it is compatible. We have not tested using openWRT.

    #38001

    john
    Participant

    At the step “update kernel” i got this message below because openWRT doesn’t recognize neither “rpi-update” nor “apt-get”

    \033[1;33mDo you have updated kernel? [Y/n] \033[0m
    n
    \033[1;33mrpi-update\033[0m
    ./install.sh: line 76: rpi-update: not found
    \033[1;33mppp install\033[0m
    ./install.sh: line 79: apt-get: not found

    Please can you make some adjustment for openWRT to make it run. thank you!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.