Home Page Forums Raspberry Pi Shields Raspberry Pi GPS Shield

This topic contains 8 replies, has 6 voices, and was last updated by  Metin 3 weeks, 3 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1352

    jana.bollineni
    Participant

    Has anyone got Raspberry Pi GPS Shield to work with Raspberry Pi? I followed the tutorial of GpsTracker.py and only see the words latitude & longitude printed, but no values. The signal LED on the GPS shield doesn’t blink either.

    Thank you.

    #1367

    Edrichardson22
    Participant

    Hi I have the same issue but cannot find any place but here to ask SixFab questions… please respond

    #1384

    Metin
    Keymaster

    Hi,

    Please use minicom and see Gps outputs. And Led blinks when Gps 3D fixed.

    #1395

    brianthompson4
    Participant

    When I just plug in a USB cable and take the shield outside I get a blue blinking light after around a minute. I am still trying to get this to occur when plugged into the raspberry pi. I am wondering how strong the antenna is. Since I plan on using this in my truck I am not too worried about it. I will post an update once I get this running on the pi.

    #1578

    buha124a
    Participant

    Has anyone ever managed to get this working?
    I connected the shield to my pi, i get the red Power led lights up and no matter what i try to run, it seems to never get a fix as lat and long always come back as 0…
    Is there something im missing?

    #1581

    lloyd.courtney
    Participant

    Having the same problem too.
    If I use it as a USB device (switch set to USB) I get a GPS signal (blue flashing light) and can read values from it. However if I use it with a Pi, I get a red power light, a green “user” light but can’t get a signal even with board in the same position.

    #1582

    buha124a
    Participant

    Then you are in a better state then i am.. even when connected with USB i never get the blue flashing light. on the pi i dont have the green “user” light either… Might it be my board is defective?

    #1583

    lloyd.courtney
    Participant

    I’ve had to leave the board on a window sill for a good few minutes before the blue flashing light comes on, so it seems to need quite a clear line of sight and some time. I also read that the antenna needs to be flat – can’t confirm if that makes a difference though.

    On another note, I tried to get it working using the USB port on a Pi Zero (W). The lights come on and eventually it gets a signal but I can’t see is show up as a device.
    I’ve tried using:
    dmesg | grep -i tty
    sudo lsusb
    But it’s just not there. Anyone else tried this?

    #34698

    Metin
    Keymaster

    Hi,

    If you attach shield via USB, You can use /dev/ttyUSB0.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.