Home Page Forums Raspberry Pi Shields Telecom carrier requires username / password authentication

This topic contains 5 replies, has 2 voices, and was last updated by  Saeed 11 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #35625

    okan-vdl
    Participant

    Hello,

    I’ve installed the SixFab PPP installer and all goes well for sim-cards that do not use authentication.
    However, my carrier requires me to enter a username and password before i can connect to the netwerk.
    Where & how could this be provided in the call script?

    Any help would be very much appreciated. I can imagine more people will run into this 🙂

    Regards,
    Okan

    #35637

    Saeed
    Moderator

    Hello Okan,

    1. Open /etc/ppp/peers/provider
    2. Remove no auth
    3. Add the following configurations
    user “YOURUSERNAME”
    password “YOURPASS”

    #35650

    okan-vdl
    Participant

    Hi Saeed,

    Thank for your reply. This does not work. It will give me the message:

    The remote system is required to authenticate itsellf but i couldn’t find any suitable secret (password) for it to use to do so.

    I think this option is only applicable if the remote system is required to authenticate.

    In my case I need to authenticate mysellf.

    I came a bit further by filling in the ‘secrets’ file and entering my username as ‘name’ parameter in the options file.

    This now leads to the message ‘CHAP Authentication succeeded’.

    Then IPCP confreq is send (addr 0.0.0.0 and ms-dns1 0.0.0.0 and ms-dns2 0.0.0.0). This makes sense because the remote host needs to determine that. However, after this the modem hangs up. So 1 problem solved (authentication) but another one arrises..

    #35651

    okan-vdl
    Participant

    Ps. and i am wondering if the authentication really works. If i use credentials which are not correct it still provides me the message ‘CHAP Authentication succeeded’

    #35662

    okan-vdl
    Participant

    Ok – Problem solved.

    Lesson 1: always connect an antenna…

    #35699

    Saeed
    Moderator

    Thank you

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.