Home Page Forums Raspberry Pi Shields Use PPP0 as a network connection for wifi hotspot

Tagged: , , ,

This topic contains 16 replies, has 2 voices, and was last updated by  Saeed 7 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #35517

    ashwin
    Participant

    I have a Sixfab 4G LTE base hat and Quectel EC25 module.
    I have been able to setup the hotspot and ppp internet connection seperately but I want to use the hotspot along with the internet connection on the rpi and it’s connected devices. How do I acheive this.
    To create a hotspot I have used https://github.com/billz/raspap-webgui

    #35519

    Saeed
    Moderator

    Please check our Hotspot using Base Shield tutorial (https://sixfab.com/using-3g-or-4g-raspberry-pi-shield-as-a-wifi-access-point/).

    #35521

    ashwin
    Participant

    Hey Saeed ,
    So to be precise:
    I have earlier tried this tutorial mentioned at https://sixfab.com/using-3g-or-4g-raspberry-pi-shield-as-a-wifi-access-point/ . This did not work , browsing through the comments section I also bumped into the [updated tutorial] part , that worked for a span that I was able to only get hotspot working and no data and wifi along with it.
    It was just a access point to maybe ssh into or something.

    Further I came across https://github.com/billz/raspap-webgui and then the hotspot seemed to be working fine. Doing that, I’ve tried editing some settings in it to make the hotspot get internet from ppp0 module.
    The ppp0 module shuts sown as soon as I start hotspot and vice versa. I’ve also tried using rc.local to start both one after the other and it did not work either.
    How can I get them both working together so I can access the internet on the client devices too?

    Help is appreciated.

    • This reply was modified 7 months, 1 week ago by  ashwin.
    #35523

    Saeed
    Moderator

    When did you try our tutorial last? I can help you with this if it is still not working.
    Seems your ppp0 connection is closed as a result once you restart you are not getting the connection. Your ppp0 should connect automatically once your Raspberry Pi is turned on

    We don’t have any idea about raspap-webgui.

    Thank you.

    #35525

    ashwin
    Participant

    Hi,
    I’ve tried the post today itself. My ppp0 connection works fine, it is just that whenever I do according to the post you mentioned neither of them work or only ppp0 works with two red crosses on the arrow symbols[clue of visual data].

    • This reply was modified 7 months, 1 week ago by  ashwin.
    #35527

    Saeed
    Moderator

    Then, I will retest them and inform you by tomorrow.

    #35535

    ashwin
    Participant

    Thank you.

    #35542

    Saeed
    Moderator

    Hi Ashwin,

    I have just tested the hotspot with ppp0 and it is working fine.
    Could you please reconfigure both PPP and Hotspot?

    #35551

    ashwin
    Participant

    Will surely try and revert back.
    Thank you.

    #35552

    ashwin
    Participant

    If I do ‘sudo service dhcpcd restart ‘ using iface static, dhcpcd cannot restart but if I say manual in the /etc/network/interfaces the dhcpcd service correctly restarts.
    What is the preferred way ?

    • This reply was modified 7 months ago by  ashwin.
    #35557

    Saeed
    Moderator

    Reboot your RPi at this moment.

    then run
    sudo ifdown wlan0
    sudo ifup wlan0

    #35589

    ashwin
    Participant

    Getting the following error while running “udo /usr/sbin/hostapd /etc/hostapd/hostapd.conf”

    ERROR :
    Configuration file: /etc/hostapd/hostapd.conf
    Line 2: invalid/unknown driver ‘nl80211 # Use the nl80211 driver with the brcmfmac driver’
    Line 3: invalid SSID ‘SIXFAB # This is the name of the network’
    Line 4: unknown hw_mode ‘g # Use the 2.4GHz band’
    Line 13: invalid key_mgmt ‘#’
    Line 15: invalid cipher ‘CCMP # Use AES, instead of TKIP’.
    FT (IEEE 802.11r) requires nas_identifier to be configured as a 1..48 octet string
    6 errors found in configuration file ‘/etc/hostapd/hostapd.conf’
    Failed to set up interface with /etc/hostapd/hostapd.conf
    Failed to initialize interface

    #35590

    Saeed
    Moderator

    Please share your /etc/hostapd/hostapd.conf file.

    #35592

    ashwin
    Participant

    /etc/hostapd/hostapd.conf file as requested.

    interface=wlan0 # This is the name of the WiFi interface we configured above
    driver=nl80211 # Use the nl80211 driver with the brcmfmac driver
    ssid=SIXFAB # This is the name of the network
    hw_mode=g # Use the 2.4GHz band
    channel=6 # Use channel 6
    ieee80211n=1 # Enable 802.11n
    wmm_enabled=1 # Enable WMM
    ht_capab=[HT40][SHORT-GI-20][DSSS_CCK-40] # Enable 40MHz channels with 20ns guard interval
    macaddr_acl=0 # Accept all MAC addresses
    auth_algs=1 # Use WPA authentication
    ignore_broadcast_ssid=0 # Require clients to know the network name
    wpa=2 # Use WPA2
    wpa_key_mgmt=WPA-PSK # Use a pre-shared key
    wpa_passphrase=mypassword # The network passphrase
    rsn_pairwise=CCMP # Use AES, instead of TKIP

    #35621

    Saeed
    Moderator

    Which version of Raspberry Pi and Raspbian are you using? Is it updated?

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.