Home Page Forums Raspberry Pi Shields Xbee shield not working on RPi3

This topic contains 0 replies, has 1 voice, and was last updated by  lorenzo.bottaccioli 7 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #36629

    lorenzo.bottaccioli
    Participant

    Hi,

    I’m trying to make the Digi Shield work on a raspberry 3. I have tryed to connect the the shield equiped with Xbee PRO S2C Zigbee antenna with both GPIO and USB but I’m not able to read recived data. The strange thing is that if I connect to a desktop pc the Shield with USB everthing work. I have tried with digi-xbee python libary (https://xbplib.readthedocs.io/en/latest/) and with xbee-python library (https://python-xbee.readthedocs.io/en/latest/). On my desktop works fine on the RPi3 is not working.

    If I do:

    On the RPi3
    I get “invalid operation mode exception”

    On desktop works fine

    If I do:

    On the RPi3 I get no msg while on the PC desktop I revice msg.

    I have also tried to use a Digi X-stick on the RPi3 and everithing works fine with the Digi Xstick.

    How can I solve this?

    Best,

    Lorenzo

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.